Bug reports
avatar
Mikhail Ter


If you found a bug, please report it in the comments. Thank you.

avatar
Spotting Limburg


EXIF dates aren't imported anymore when uploading a picture.
avatar
Mikhail Ter


fixed, thanks!
avatar
hanssmit53


Location field doesn't give suggested/known names anymore
avatar
Mikhail Ter


Need more details to fix it:

1) The URL to the picture
2) Your input in the location field
3) Your browser version and OS version.

Thanks!
avatar
Robertas Š.


Need to fix the Latvian and Lithuanian private owners category. By choosing @private-lt in the brackets is written "(Private owners group, Latvia). In this case should be Lithuania (LT-Lithuania, LV-Latvia). This is why one of my pics taken in Lithuania has appeared in Latvian gallery http://trainspo.com/photo/25985/?li..hoto.
avatar
Mikhail Ter


Many thanks for this report, all has been fixed.
avatar
Pierre-Noël Rietsch


The last times, nothing happens when I upload a picture. Neither the newer ones nor the older ones (one uploaded in September last year, 9 months ago!emojione get approved or even rejected.
Question: How much "waiting" or "new viehcles" pictures are still waiting...?
avatar
Mikhail Ter


We have changed process of moderation of the new pictures, so now is't better to follow site instructions "If you do not receive new slots for a long time, maybe it makes sense to remove the unsuccessful photos and upload new ones."

Please read more detailed explanation: http://trainspo.com/help/#moderation
avatar
Pierre-Noël Rietsch


OK, I just deleted 2 pics and uploaded 2 fresh ones. Let us see what happens...
A
Aleix Cortés


I have 3 pictures in moderatio for a long time. When I upload a new image the moderator change the status to OK or DB, but on this three the status is always the same, waiting.
avatar
Mikhail Ter


Dear Aleix, we are community moderated site. Please read details of the moderation process here:
http://trainspo.com/help/#moderation
avatar
Nielske1990


Why is it that some users can upload poor quality pics which are added almost immediately, while other members have to wait until they die before their good pics will be approved. And yes, I know how the moderation works, but its such a strange mechanism.
It looks mostly like cronyism, that it becomes quite hateful for me and (reading these comments above) also for others.

Don't get me wrong, I like the idea of Trainspo and I think it's a great initiative. Nevertheless I'm starting to think of deleting my photo's, comments and even my account for it... Too bad... emojione
avatar
Spotting Limburg


I see the system has a hard time recognizing locomotive-numbers which beside numbers also use characters in it. Example: http://trainspo.com/class/239/ See captured numbers.
avatar
Mikhail Ter


Has been fixed with the last site update.
avatar
RL


I noticed that all my pictures are now cropped from the right side.. is this also part from the last update?
avatar
Mikhail Ter


Pictures are smaller for 10px if your display width is 1024px or less. Please check on the larger displays.
avatar
Spotting Limburg


The SNCB type 77 should be split into a type 77 (numbers 7701 till 7799) class and a type 78 (7800 till 7899) class. http://trainspo.com/class/1189/
avatar
sameer7678


I uploaded the same picture thrice just because for some reason I couldn't see my own uploads. Then later saw those same uploads in my gallery and deleted the extra two and also fill out the description later but now that the picture is still showing 'waiting' status. This has never happened before. Is this some kind of bug..?
avatar
Mikhail Ter


No, it's normal situation. Please read how our moderation process works: http://trainspo.com/help/#moderation
avatar
Jayasankar Madhavadas


When ever I upload the picture, the date of picture is taken as date on which the picture is uploaded. My latest upload picture was on 17th Oct 2012 but when the upload happened , it came as 27th Jan 2013 and Day1 seal came over the picture. I believe it is winter currently in Europe and certain pictures from EU region has summer climate with Day1 stamp on it. Why is this happening ? Why the database is not extracting date from EXIF data ?
avatar
Mikhail Ter


Normally Trainspo try to get date from EXIF data, if it's not present, it take date from file modification time. If your picture has incorrect date, you can always edit it and enter correct date, and try to comment on EU pictures where you see incorrect date too. Thanks.
avatar
Jayasankar Madhavadas


It seems only my friend Ami Verma faced the same issue. I shall look to ensure that the date of pic is same as date taken through the edit option.

Thanking you

Jay
avatar
Jayasankar Madhavadas


Today , as I uploaded the picture, the date was taken properly .

Thanks

Jay
avatar
Nielske1990


Why is it, that some newly discovered classes are in the list on the frontpage and some are not. Like this class: http://trainspo.com/class/6152/ First discovery was my photo today, and it is not in the list. Same with this class for example: http://trainspo.com/class/6143/ First uploaded picture was this week, but I don't see it back in the frontpage-list. Meanwhile, some other classes I added do appear in that list. Where is the difference between these?
avatar
Mikhail Ter


Seems like a bug and must be fixed, thank you.
avatar
Jim K


APA (Apache Railroad) is located in Snowflake, Arizona,USA not in Canada as identified by your database.
avatar
Mikhail Ter


Thanks, has been fixed.
avatar
Spotting Limburg


http://trainspo.com/operator/1763/

Both steam locomotives from this operator should be moved to:

http://trainspo.com/operator/1431/
avatar
Kittitat Keeratinijakan


http://trainspo.com/operator/1710/

A short name of this operator should be "TPIPL" as shown in their trademark and used in the Stock Exchange of Thailand.

http://www.tpipolene.co.th/ENG/Imag..O.gif
http://www.set.or.th/set/companypro..TPIPL

Thanks.
Y
Yuri Zhuck


Done.
Y
Yuri Zhuck


Updated.
Y
Yuri Zhuck


Information added.
avatar
sameer7678


Subject To 'Like' Button.

Just came to my notice through some of my followers that they are not able to 'like' my pictures (pre approval) in their flow. Is that a BUG???
I still have 2 pictures "in moderation" including one "new vehicle", some of them since few days! I also sent reports with all "new vehicles", if you need additional info's, please ask me! Did they got completely forgotten or is it because of that 'like' button problem (bug)..? Due to that, I'm unable to get any 'likes' on any of my uploads. which are necessary as per your moderation process works: http://trainspo.com/help/#moderation.

Regards

Sam
avatar
paul.zimmer


Curiously my gallery/summary doesn't show the pictures in the right order.
Normally these pages show the newest pictures first,
but on my pictures some older photos are the first in the order.
Please repair this mistake.

Thanks and best regards
Paul
avatar
Mikhail Ter


Please give more details about this problem. Just tell which pictures are not in correct order.
avatar
Mikhail Ter


No, this is not a bug. Picture can't be liked until right class assigned.
Y
Yuri Zhuck


For some reasons a piece of photo is "cut", when it's displayed on the page. For example, on this photo: http://trainspo.com/photo/37758/ a strip on the right is absent, that can be seen from copyright.
avatar
Pierre-Noël Rietsch


Still the problem of waiting... I have actually 5new vehicles and 3 "waiting" since several weeks, and nothing happens...
Would it perhaps not be possible to do a quick process by giving the moderator(s) the right to set pictures to Ok without waiting for the votes, when they are obviously Ok?
avatar
UnterStrom


What news on implementing image fitting behaviour in full-view? That still spoils all the fun emojione
avatar
Mikhail Ter


It's the old bug, still need to fix it. It's fixed on retina pages.